BETA

1st December 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [01/12/19 01:34 AM] with 'Major Outage'

Issue has been resolved at [01/12/19 02:54 AM]