BETA

1st December 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [01/12/19 01:24 AM] with 'Major Outage'

Issue has been resolved at [01/12/19 01:34 AM]