BETA

1st December 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [01/12/19 01:24 AM] with 'Major Outage'

Issue has been resolved at [01/12/19 01:44 AM]