BETA

1st December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [01/12/19 01:24 AM] with 'Partial Outage'

Issue has been resolved at [01/12/19 01:34 AM]