BETA

14th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/05/17 02:44 AM] with 'Partial Outage'

Issue has been resolved at [14/05/17 02:59 AM]