BETA

30th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [30/11/19 08:45 PM] with 'Major Outage'

Issue has been resolved at [30/11/19 08:54 PM]