BETA

30th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [30/11/19 05:14 PM] with 'Partial Outage'

Issue has been resolved at [30/11/19 05:15 PM]