BETA

30th November 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [30/11/19 04:34 PM] with 'Major Outage'

Issue has been resolved at [30/11/19 04:54 PM]