BETA

13th May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [13/05/17 12:30 PM] with 'Partial Outage'

Issue has been resolved at [13/05/17 12:31 PM]