BETA

30th November 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [30/11/19 04:04 PM] with 'Partial Outage'

Issue has been resolved at [30/11/19 04:05 PM]