BETA

30th November 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [30/11/19 03:54 PM] with 'Partial Outage'

Issue has been resolved at [30/11/19 04:14 PM]