BETA

30th November 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [30/11/19 01:14 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/11/19 02:15 PM]