BETA

30th November 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [30/11/19 01:14 PM] with 'Partial Outage'

Issue has been resolved at [30/11/19 01:24 PM]