BETA

30th November 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [30/11/19 12:14 PM] with 'Major Outage'

Issue has been resolved at [30/11/19 12:34 PM]