BETA

30th November 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [30/11/19 12:04 PM] with 'Major Outage'

Issue has been resolved at [30/11/19 12:35 PM]