BETA

30th November 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [30/11/19 11:05 AM] with 'Partial Outage'

Issue has been resolved at [30/11/19 11:15 AM]