BETA

30th November 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [30/11/19 10:14 AM] with 'Major Outage'

Issue has been resolved at [30/11/19 03:44 PM]