BETA

30th November 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [30/11/19 10:04 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/11/19 03:44 PM]