BETA

30th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [30/11/19 09:54 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [30/11/19 04:24 PM]