BETA

29th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [29/11/19 05:45 PM] with 'Partial Outage'

Issue has been resolved at [29/11/19 06:14 PM]