BETA

13th May 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/05/17 09:16 AM] with 'Major Outage'

Issue has been resolved at [13/05/17 09:17 AM]