BETA

29th November 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [29/11/19 05:34 PM] with 'Partial Outage'

Issue has been resolved at [29/11/19 05:54 PM]