BETA

29th November 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [29/11/19 03:55 PM] with 'Partial Outage'

Issue has been resolved at [29/11/19 04:04 PM]