BETA

13th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/05/17 09:16 AM] with 'Partial Outage'

Issue has been resolved at [13/05/17 09:17 AM]