BETA

29th November 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [29/11/19 02:15 PM] with 'Partial Outage'

Issue has been resolved at [29/11/19 02:24 PM]