BETA

13th January 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/01/19 01:59 PM] with 'Major Outage'

Issue has been resolved at [13/01/19 05:12 PM]