BETA

29th November 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [29/11/19 12:34 PM] with 'Major Outage'

Issue has been resolved at [29/11/19 01:54 PM]