BETA

29th November 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/11/19 11:54 AM] with 'Major Outage'

Issue has been resolved at [29/11/19 12:05 PM]