BETA

13th May 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/05/17 09:07 AM] with 'Partial Outage'

Issue has been resolved at [13/05/17 02:29 PM]