BETA

29th November 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [29/11/19 11:34 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/11/19 03:44 PM]