BETA

29th November 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [29/11/19 11:25 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/11/19 05:24 PM]