BETA

29th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [29/11/19 11:24 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/11/19 05:44 PM]