BETA

29th November 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [29/11/19 11:24 AM] with 'Major Outage'

Issue has been resolved at [29/11/19 04:54 PM]