BETA

24th November 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [24/11/19 02:49 PM] with 'Partial Outage'

Issue has been resolved at [24/11/19 03:09 PM]