BETA

12th May 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/05/17 03:22 PM] with 'Partial Outage'

Issue has been resolved at [12/05/17 03:23 PM]