BETA

11th January 2019

Pune Issue observed for 'Outgoing Calls' in Pune Region

Identified at [11/01/19 03:28 PM] with 'Major Outage'

Issue has been resolved at [11/01/19 03:30 PM]