BETA

24th November 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [24/11/19 10:00 AM] with 'Partial Outage'

Issue has been resolved at [24/11/19 11:59 AM]