BETA

24th November 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [24/11/19 12:50 AM] with 'Major Outage'

Issue has been resolved at [24/11/19 01:30 AM]