BETA

24th November 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [24/11/19 12:49 AM] with 'Major Outage'

Issue has been resolved at [24/11/19 01:29 AM]