BETA

24th November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [24/11/19 12:29 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [24/11/19 02:09 AM]