BETA

23rd November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [23/11/19 01:19 AM] with 'Partial Outage'

Issue has been resolved at [23/11/19 01:29 AM]