BETA

22nd November 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [22/11/19 02:39 PM] with 'Partial Outage'

Issue has been resolved at [22/11/19 02:49 PM]