BETA

12th May 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/05/17 12:38 PM] with 'Major Outage'

Issue has been resolved at [12/05/17 12:40 PM]