BETA

22nd November 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [22/11/19 02:20 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/11/19 07:50 PM]