BETA

22nd November 2019

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [22/11/19 02:20 PM] with 'Major Outage'

Issue has been resolved at [22/11/19 07:50 PM]