BETA

22nd November 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [22/11/19 02:19 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [22/11/19 07:59 PM]