BETA

22nd November 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/11/19 02:19 PM] with 'Major Outage'

Issue has been resolved at [22/11/19 07:49 PM]