BETA

20th November 2019

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [20/11/19 01:10 PM] with 'Major Outage'

Issue has been resolved at [20/11/19 01:19 PM]