BETA

19th November 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [19/11/19 11:50 AM] with 'Major Outage'

Issue has been resolved at [19/11/19 11:59 AM]