BETA

18th November 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [18/11/19 01:14 PM] with 'Partial Outage'

Issue has been resolved at [18/11/19 01:24 PM]